SNAP PAC RESTful API to Excel Spreadsheet

About this Tutorial

This technical note describes how to read from and write to an Opto 22 SNAP PAC
programmable automation controller via the PAC's RESTful API, using Visual Basic for
Applications (VBA) with Microsoft Excel. In this way you can securely share I/0 point and
variable data in your SNAP PAC controller with an Excel spreadsheet.

If you have not already done so, download sample spreadsheets in the SNAP PAC RESTful
API to Excel Spreadsheet Example on our website at www.opto22.com. Once
downloaded, you can immediately use them to read and write to your SNAP PAC.

The download includes these files:

«  Opto22_RESTfulPAC_ReadingWritingCharting.xlsx—A macro-enabled Excel file
containing three spreadsheets and Visual Basic code. These spreadsheets require
only the name or IP address of a PAC and the login and password for a user with
Read and Write privileges. (See "Prerequisite: Setting Up the PAC"on page 2.

«  JsonConverterbas—A third-party class for VBA created by MIT (copyright Tim Hall,
https://github.com/VBA-tools/VBA-JSON). This file is available for general use as
long as the provisions in its copyright are preserved.

o 2203_SNAP_PAC_RESTful_API_to_Excel_Spreadsheet_Technical Note.pdf—(This
document)

The first part of this tech note explains the sample spreadsheets. The optional second
part of the tech note explains step by step how to create a spreadsheet of your own, if
you wish to.

Questions about this tutorial can be addressed to Support@opto22.com.

About the RESTful API

The REST APl s a way for software applications to securely access data in an Opto 22
SNAP PAC controller by making GET and POST requests. The complete Opto 22 RESTful
APlis documented here:

http://developer.opto22.com/static/generated/pac-rest-api/swagger-ui/index.html

At this link you'll find URL paths to read any data available to the PAC Control strategy
running on the PAC and to write to the same data, if it is a writable data type. All the GET
and POST requests return information in standard JavaScript Object Notation (JSON).

The sample Excel file uses the PAC's RESTful APl and common Excel features to create an
interactive spreadsheet that can query your PAC and then build URL paths for the data in
your control strategy. You don't need to know the I/0 point and variable names on your
PAC, because the Excel sample can read the /0 and variable names and will create the
paths. To see how to construct the HTTP requests and parse the returned data, you'll look
in the Visual Basic code included in the Excel sample. We'll explore the code below.
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Prerequisite: Setting Up the PAC

Before you begin, enable the RESTful interface on the PAC and create a user account with read
and write privileges as described in the SNAP PAC REST API Quick Start, which is available at
http://developer.opto22.com/rest/pac/quickstart/

About the Sample File

If you're an experienced Excel user, you may wish to start by examining the sample file. The
following images provide an overview.

Reading spreadsheet

Choose a general type of data
to begin constructing a read
command. This drop-down
selects from I/0, variables, or
table variables.

This list is populated after you
select a general data type. The
selection you make completes a
read command that is sent to the
PAC. Both the read command and
return data appear in cells.

This list is populated after you
select a specific group. Make a
selection here to request a specific
item. The read command and
return data appear in cells.
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Replace information in these fields with your
PAC's address and the username and
password that is defined on your PAC.

and password. Select general type of data to initiate searcl
Provide IP Addrebs  http://restpac.groov.com Ejemples: http://10.1.15.1 https://102.20.123.54

o
o
[ =]
T — =] (Select new value from menu to call for data)
- iy [ =]  (Select new value from menu to call for data)
Enter index (i a table variable): (Leave index blank to get the whole table)
URL to PAC:
Re-send JSON returned:
Clear values Value(s) parsed:

®

Reading [ERUTIHLE] Charting



http://developer.opto22.com/rest/pac/quickstart/
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Writing spreadsheet

Replace the information in these fields with
your PAC's address and the username and
password that is defined on your PAC.

Use these three drop-down lists
to identify a specific I/O point,
variable, or table variable to
write to.

Provide IP Addrefs
User nam:
Passworlfl:

|

Enter the information to write in these fields. Each
cell is used for a different type of variable. The write
function in Excel will choose the appropriate field
based on the type of data you select.

ter you PAC's domain name or IP address and the user name and password. Selec

i |
e or IP address and the user nan
http://restpac.groov.com  Ej
w (

T |p|

ke and password. Select generfl type of data to initiate searches
amples: http://10.1.15.1 htjjps://102.20.123.54
bgin must have read/write pefmission)
w

Choose specific group:
Choose point or variable by name:

To read a specific table variable
index, type a valid index for the
table here. This field defaults to
0and is ignored if other than a
table variable is requested.

T

Re-send Read command
Clear

Click this button to re-send
the read command so you can
verify the write command.

=G Writing

If integer, float, or string

<— Write | 95.98
99

"String"

If Discrete:

If array
[1,2.2,3.4,29, 60]
["string 1", "string 2"]
Start Index: T
URL Sent
Data Packet:
Returned:

Charting

@
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Charting spreadsheet

The Charting sheet shows how to call data on a timed interval. The data are displayed in cells
andin a chart.

Replace the information in these fields with
your PAC's address and the username and
password that is defined on your PAC.

Use these three drop-down lists
to identify a specific IO point, _ i .
variable or table variable to
write to.

=
s
o
m

Choose PAC:
PAC Address http://restpac.groov.com

To read a specific table variable
index, type a valid index for the
table here. This field defaults to 0
and is ignored if other than a table
variable is requested. Click the
Update button to ensure that a
change to a table index is included
in the data source.

user names: nw

user password: rw 100
& T 7 Update |
Add data graph | 0.40

Remove selected graph
Graphs being plotted: | -|

0.00

Put data at line: 15 Start Timer | 12:00:00 AM 4:48:00 AM  9:3¢
Timer interval (seconds) 0:00:07 Stop Timer |

Y

The I/O point, variable, or table
variable read command is
displayed here. Click Add data
graph to place the value in the
Graphs being plotted drop-down
list. Select the item to remove it.

Be careful changing these values.
The line value places the data
into the spreadsheet where the
chart will use it. If you change the
placement, you will also need to
change the chart.

3 Reading Writing Charting ®

Type a new time interval if desired.

These buttons stop and start the live charting of data.
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Visual Basic Behind the Spreadsheets

 e—aree
0
b X Cut
Em Copy
‘DI Paste
Grouping 4
Order 4
- Assign Macro T X
o, . _— “| Macro name:
s omettontiol Opto22 RESTIUIPAC readingWritingChartingxismiShestd.cho F: Edit
Sheet3.dataClass -

Sheet3 dataFamily
Sheet3.newGraph

Sheet3. removeGraph
Sheet3.resendUrl

Sheet3 Selectlame

Sheet3 StartTimer

Sheet3 Stop_Timer
Sheetd.chooseGenType
Sheetd.chooseSpecificType
Sheetd. clearValues

Sheetd resendUrl ol
Macros in: | All Open Waorkbooks g
Description

The code that reads, writes, and plots data resides in the spreadsheet as modules and macros.
Macros are run from controls placed in the spreadsheet. To see the list of macros that can be
assigned to a control (such as a drop-down list or button), right-click the control.

To see the content of macros, first open the Visual Basic Editor. The VBA editor is available from
the Developer menu. Note that the Developer menu is not displayed by default.

To display the Developer menu:

1. Choose File -> Options.

In the options win, select Customize Ribbon.

Select Developer under Main Tabs and close the Options window.
Select the Developer menu.

Select the Visual Basic icon.

VoA W N
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Each macro is defined by “Sub”
and “End Sub”

Each sheet has a window for

ﬁ Micresoft Visual Basic for Applications - Opte22 RESTRulPAKC_readingWiitingChartingadsm

VBA code. The code for each Ele Edit View Inset Format Debug Run Togk Add-lns Window Help
sheet was placed here for E2-d A# 9 » 1 @MY FY 5 @ nscon
organizational purposes. |ijxt-mprcge:t x|
== &) Opto22 REfTFuIPAC readingWritingChartingdsm - Sheet3 (Code)
The workbook code is a place == = || [(Generan v ~] [star

for commonly available — =
functions and startup routines.

JsonConverter is a module written il
by MIT and made publicly available. —-:
It may be used according to terms

of its copyright statement.

The Chart’s timer public variables
and functions are contained in
this module.

VBAProject (Opto22_ RESTfulPAC_
£5 Migosoft Excel Objects

Sub StartTimer()
Dim ws As Worksheet: Set ws = Worksheets("Charting")
'get timer interval and starting line number

LineCount = w=.Range ("B12") .Value
TimerTnterval = ws.Range ("B13") .Value
Hodulel.Start_Timed

Sub
Stop Timer()
TimerActive =

False

i Sub

removeGraph ()

Dim ws As Worksheet: Set w3 — Worksheets("Charting")
Dim dd As Object: Set dd = ws.DropDowns ("_graphsDD")
If dd.listcount > 0 And dd.ListIndex > 0 Then

[1Generan

Public
Public
Public

TimerActive As Boolean

TimerInterval BAs Date

Sub Start_Timer()
TimerAcrive = True
Application.OnTime How()

" Application.OnTime

End Sub

(Optional) Setting up the Excel Development Environment

You can use the spreadsheets just as they are to read and write to your SNAP PAC. However, if

you want to understand more about how it was built or build your own, this last section shows
you step by step how to create a new spreadsheet, use the Visual Basic Editor, and write a macro
to read data from your PAC.

If you are creating a new Excel spreadsheet, you will need to create a macro-enabled
spreadsheet and add resources to the Visual Basic editor.

Create a macro-enabled spreadsheet

1.

Create a new file in Excel.

2.  When saving, choose Excel Macro-Enabled Workbook.

When you save the file this way, the filename ends in xIsm.
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d
H

=
=
-

Organize »

# Hide Folders

Save As

4 s ThisPC » Documents

New folder

I This PC
[ Desktop

(1]

Documents

* Downloads

Music Adobe

[&] Pictures

Videos
Local Disk (C:)
Runtime (\\000eng.opto22.com) (G:)

HORAE AANNShares nntn?? cami (H

v | O Search Documents »

E
L

PAC Praject 9.5 -
Examples

Customn Office
Templates

File name: | Bookl.xdsx

Save as type: | Excel Workbook (*xlsx)

Excel Workbook (*.adsx)

BRI | Macro- Enabled Workbook

Excel Binary Workbook (*xlsb)

Excel 97-2003 Workbook (*.xls)

XML Data (*.xml)

Single File Web Page (*.mht;*. mhtml)
‘Web Page (*.htm;*.html)

Excel Template (.t

Excel Macro-Enabled Template (*xltm)
Excel §7-2003 Template (*.xIt)

Text (Tab delimited) (*.bd)

Unicode Text (*txd)

XML Spreadsheet 2003 (*xml)
Microsoft Excel 5.0/95 Workbook (*xls)
CSV (Comma delimited) (*.csv)
Formatted Text (Space delimited) (*.prn)
Text (Macintosh) (*.bd)

Text (MS-DOS) (*.bet)

CSV (Macintosh) (*.csv)

CSV (MS-DOS) (*.csv)

DIF (Data Interchange Format) (7.dif)
SYLK (Symbolic Link] (*.slk)

Excel Add-in (*xlam)

Excel §7-2003 Add-in (*.xla)

PDF (*.pdf)

XPS Document (*xps)

Strict Open XML Spreadsheet (*.xlsx)
OpenDocument Spreadsheet (*.ods)

Enable the developer tool bar

1. Choose File > Options.
2. Choose Customize Ribbon.
3. Under Main Tabs, select Developer.
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OptoRESTFUIPAC xlsm - Excel

. ~
Excel Options ?
General . :
L=l Customize the Ribbon.
Formulas
on Choose commands from: Customize the Ribbon: (i1
S Popular Commands Main Tabs i
Save
Language Y Add or Remove Filters |Main Tabs
All Chart Types... Background Removal
Advanced Borders |» Home
Save as Adobe Calculate Now Clipboard
PDF = Center Al
Quick Access Toolbar EE) Conditional Formatting * Alignment
ER Copy
Add-ins Custorn Sort...
db Cut Cells
Trust Center A Decrease Font Size Editing
%’: Delete Cells... Insert
X Delete Sheet Columns e
ZX Delete Sheet Rows Sl
@ i Add » Formulas
£ Fill Color |» R Data
Font I- Review
Publish A Font Color L4 View
S -
Close Format Cells Wi
Format Painter g
Freeze Panes r ACROBAT
’ Increase Font Size
Ac(cy Insert Cells...
X Insert Function...
Optians o Insert Picture
M Insert Sheet Columns o, Wit l e
= |nsert Sheet Rows - — .
Feedback Insert Table Customizations: Reset v |00}
Macros I S
Merge & Center e

4. C(lose the Options dialog box and return to the spreadsheet.

Open the Visual Basic editor

1. Choose the Developer tab.
2. (Choose the Visual Basic button. This opens the VBA Editor in its own window.
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Visual Basic (Alt+F11)
Open the Visual Basic editor.

Sheetl

®

a Microsoft Visual Basic for Applications - Book1

File Edit View Inset Format Debug Run  Teols Add-lns Window Help

EHE-H Y aaao2¢» g SEEY 210

Project - VBAPraject

==
-2 VBAProject (Book1)
= @ Microsoft Excel Objects
-8 sheetl (sheet1)
48] ThisWorkbook

Add VBA references

The VBA editor defaults to a minimum set of libraries enabled. You will need to add more.
Choose Tools > References.

1.
2.

Find the following libraries and select each.

Visual Basic For Applications

Microsoft Excel 16.0 Object Library
OLE Automation

Microsoft Office 16.0 Object Library
Microsoft Internet Controls

Microsoft WinHTTP Services version 5.1
Microsoft XML v6.0

Microsoft Scripting Runtime

Microsoft Forms 2.0 Object Library
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@ Micresoft Visual Basic for Applications - Book1

EEEEE Edit Miew Insert Format Debug Run | Tools | Add-Ins  Window Help

E -Hl ¥ EBERAl9 > References...
Project - VBAProject EI Additional Controls...
! Macros..,
=& VBAProject (Book1) Options...
&=-{E3 Microsoft Excel Objects VBAProject | References - VBAProject
BH) Sheet1 (Sheet1) o
35 ThisWorkbook Digital Signg

Available References:

Visual Basic For Applications

Microsoft Excel 16,0 Object Library
OLE Automation

Microsoft Office 16,0 Object Library
Microsoft Internet Controls

Microsoft WinHTTP Services, version 5.1
Microsoft XML, v6.0

Microsoft Scripting Runtime

Microsoft Forms 2.0 Object Library
UMNSAVED: VBAProject
AccessibilityCplAdmin 1.0 Type Library
Acrobat

Acrobat Access 3.0 Type Library
Arrohat Distiller

=
I
e
[
I
I
I
I
c
O
O
O
O
[
<

Acrobat Scan 1.0 Type Library

Location:  C:\Program Files (x85)\Adobe \Acrobat DC\Acrobat'plug_ins'\s:
Language: Standard

3. Click OKto close.

Create a Read command

Write code to read from the PAC

To read data from the PAC, you'll create a macro, which is Visual Basic code attached to the
spreadsheet.

1. Inthe VBA Editor, double click “Sheet1” (or the name you used if you renamed the sheet).
2. Create a subroutine by typing: Sub ReadPoint()

As soon as you press Return, the text End Sub will be added. All code added between
Sub and End Sub will make up the body of the macro.

In this tutorial, you'll enter the body of the macro in two parts. First, you'll enter the code
that will retrieve data and display it so that you can see the format of the data returned.
Second, you will import a JSON parsing module to convert the returned JSON string into
an easy-to-use value.

3. Copyand paste (or type) the following text between Sub ReadPoint() and Sub End.
The text is annotated to explain what each section does. Lines beginning with an
apostrophe are comments and will appear in green in the VBA Editor. You'll need to
customize the text in italics to your application as described in the accompanying
annotations.

" Create an object reference to the Excel worksheet
Dim ws As Worksheet: Set ws = Worksheets(''Sheetl')

"Create a string that will be the URL write command
Dim strUrl As String
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“In the following line, substitute restpac.groov.com and
Lamp_Temperature/eu
‘with the address of your PAC and name of your point or variable.
For points, include “/eu”.
strurl =
"https://restpac.groov.com/api/vl/device/strategy/ios/analoglnputs
/Lamp_Temperature/eu"
"Build HTTP request
Dim hReq As New WinHttpRequest
hReq.Open "GET", strUrl, False
hReq.SetRequestHeader 'Content-type", "application/json"
hReq.SetCredentials "username', "password", O "Replace username
and password with name and password

“defined for your PAC
hReq.Send
"Read the return from the PAC. The return information will be a
JSON string
Dim strResp As String
strResp = hReg.ResponseText
“This will place the returned JSON string in cell 2B.
ws.Cells(2, 2).Value = strResp

After entering this code, your macro should appear as shown here:

a Microsoft Visual Basic for Applications - Book1xlsm

B8 VBAProject (Booklxdsm)
El-£25 Microsoft Excel Objects

; 48" ThisWorkbook
El-45 Modules
¥ JsonConverter

Eile Edit Miew Insert Format Debug Run Tools Add-Ins  Window Help
HE--d e Y] o @ s EY @ | n29,Calts B
Project - VBAProject 25]
&% Bookl.xlsm - Sheet1 (Code)
EEIR E :
| ~~| |Readpoint

Sub ReadPoint ()

End Sub

E

L

' Create an object reference to the Excel worksheet

Dim ws As Worksheet: Set ws = Worksheets ("Sheetl™)

'Create a string that will be the URL write command

Dim stxUrl As String

strUrl = "http://restpac.groov.com/api/vl/device/strategy/ios/analoglnputs/Lamp Temperature/eu”

'Build HTTP request

Dim hReqg As New WinHttpRegquest

hReqg.Open "GET", strUrl, False

hReq.5etRequestHeader "Content-type”, "application/json™

hReq.SetCredentials "rw™, "rw", 0 'Replace username and password with name and password defined
hReg.S5end

'Read the return from the PAC. The return information will be a JSON string
Dim strResp As String
strResp = hReq.ResponseText
'Create an object usaing the JsonConverter library to read the value from the JSON string.

ws.Cells (2, 2).Value = strResp

L Dim json As Object
S5et json = JsonConverter.ParseJson(strResp) 'Use MIT JsonConverter class
Dim tempStr As String
tempStr = json("wvalue™) '"wvalue™ is the name returned in the JSON. For digital points, use "state™
'See the Opto RESTful API for full set of returned names

'Display the parsed value in an cell
ws.Cells(Bl, 2) .Value = tempStr 'Write the wvalue to a cell

tl 4

4,

Save your changes.
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Call the macro from the spreadsheet

1. Return to the Excel sheet.

2. Resize columns A and B to provide space for drawing a button. Resize by positioning the
mouse over the column divider. When the cursor changes to a divider, click and drag the
column divider.

Book] - Excel

T =
v Tell me

Home Insert Page Layout Formulas Data Review View ACROBAT

27 Record Macro a & E‘:ﬂ ;- M Properties EE FEMEP Properties @Impnrl

E Use Relative References = &1 View Code ,,,‘% Expansion Packs Eq., Export
Add-  Excel COM Insert  Design Source
! Macro Security ins  Add-ins Add-ins | -  Mode |4 Run Dialog [#1 Refresh Data

Code Add-ins Controls

3. (lickthe Developer tab to display the Developer tools.

4. Open the list of Form Controls by clicking the Insert button, and choose the button icon
(top left Form Control in this picture):

o
W

Home Insert Page Layout Formulas Data Review

’ g *:C_: M Properties EE T2 Map Properties B33 Impart
o = & View Code 12 Expansion Packs [, Export
Add-  Excel COM Design -~ Source
ins  Add-ins Add-ins Mode (3] Run Dialog £*1 Refresh Data
Add-ins | ‘

Form Controls XML

BMEEe
Aa B Bl g
ActiveX Controls

D e 5
Healz2ll

—— #7Record Macro
=L! ﬁ Use Relative References
Visual Macros

! Macro Security
Code

5. (lickand drag in the spreadsheet to create the button.
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Home Insert Formulas Data

Page Layout

Jook] - Excel

You can resize and reposition the button after you draw it.

As soon as you draw the button, a Macro window appears. The macro you created should

be visible in the window:

Bg

Formulas Data Re

Assign Macro

Macro name:

Format

Button_Click

Sheetl ReadPoint

Macros in: | All Open Workbooks

Description

Select Sheet1.ReadPoint and click OK.

Change the name of the new button by right-clicking the button. Position the cursor over
the text, click the text, and type a new name, such “Read Point.”

Test by clicking the Read Point button.

The return string appears in cell 2B:

TECHNICAL NOTE - Form 2203-161202 13
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Bookl.xlsm - Excel

Home Insert Page Layout Formulas Data Review View ACROBAT ':;:' Tell me what yo

%‘ﬁmiwm a g L—V* ﬂ g;m D (7Y Map Properties B2 Import

-, D) Epansion Pocks 7L, Fport

Add- Excel COM | lnsert
s E!uehshum

ins  Add-ins Adeins |+ Mode [3) Run Dialog
Add-ins gungn;s

{"value":7.22704163e+01}

Read Point |

The return string’s value varies in type according to the type of data returned. This example
returned a float variable that needs to isolated from the string and converted to a standard
number.

Parse the JSON string

Import the JsonConverter module.
1. IntheVBA Editor, choose File > Import File.
2. Navigate to the file JsonConverter.bas, select it, and choose Open.

4 Microsoft Visual Basic for Applications - Booklxlsm
File | Edit View Inset Format Debug Run Jools Add-lns  Window Hel
g p
[ SaveBooklxism .S WY @ | Ln25, Col1 p
P Import File... Ctrl+
Export File. Ctrl+E =l
| ~+| |ReadPoint
g
& print.. cup | & imponFile =3
XK Close and Return to Microsoft Excel  Alt+Q) 1 > ThisPC > Local Disk (C) » restful_pac > VBA-JSON-master > v|®| | Search VBA-JSON-master o
Dil  Organize New folder =~ O @
st i
IS
.= EThisPC Mame
Di I Desktop specs
hR = ] JsenCenverter.bas
¥ || Documents
hR - Downloads
bR D Music
'R [&] Pictures
Di
o B videos
' %, Local Disk (C:)
“ = Runtime (\\000eng.opto22.com) (G} No preview available.
= HOME [\\000Shares.opto22.com) (H:)
Fndl /Suj = USEs (\\00OMktng.opto22.com) (k)

= USEe (\DDDEng.opto22.com) (1)

= NETAPPS (\\000Shares.opto22.com} (K:)
= OFF_2k_1 (\\000Shares.opto22.com) (M:)
= OFF_2k_2 (\\000Shares.opto22.com} (N:)
= OUTLK_2003 (\\00DShares.opto22.com) (O:]
= Production (\\000Eng.opta22.com) (C:)

File name: | JsonConverter.bas v‘ VE Files (%frm;" bas;".cls) v
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The JsonConverter module appears in the Project tree. Expand the Modules folder to see
the JsonConverter. You do not need to open JsonConverter for this tutorial.

E Microsoft Visual Basic for Applications - Book1.xlsm

File Edit View Insert Format Debug Run Tools Add-lns Window Help

E- pouE R EEY 2@
Project - VBAProject *
ooklxlsm - Sheet €]
Book1xlsm - Sheet? (Cod
=] =
-} | ) I
El-# VBAProject (BookLxlsm) =
[E-£25 Microsoft Excel Objects Sub ReadPoint ()
#] Sheetl (Sheet1) ' Create an object reference to the Excel wo:
487 ThisWorkbook Dim ws As Worksheet: Set ws = Worksheets ("Shi
s 'Create a string that will be the URL write .
=) @ Modules & , ;
L4488 JsonConverter Dim strUrl As String

strUrl = "http://resctpac.groov.com/api/vl/de

'Build HTTP request

Dim hReq As New WinHttpRequest

hReqg.Open "GEI™, =strUrl, False
hReq.SetRequestHeader "Content-type™, "applis
hReq.SetCredentials "username™, "password™, |
hReqg.Send

'Read the return from the PAC. The return in
Dim strResp As String
strResp = hReg.ResponseText

'Create an object using the JsonConverter 1.

ws.Cells (2, 2).Value = strResp

End Sub

3. Add the following code at the end of your subroutine (macro) within the body of the

Macro:

"Create an object using the JsonConverter library to read the value
from the JSON string.

Dim json As Object

Set json = JsonConverter._ParseJson(strResp) “"Use MIT JsonConverter
class

Dim tempStr As String

tempStr = json(“'value'™) ""value™ is the name returned in the JSON.
For digital points, use "state"

"See the Opto RESTful API for full set of returned names

"Display the parsed value in an cell

ws.Cells(3, 2).vValue = tempStr “Write the value to a cell

4. Saveall changes.
Your macro should appear as shown here:
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ﬂ Microsoft Visual Basic for Applications - Book1.adsm

 FEle Edit View [nsert Format Debug Run  Tools Add-lns  Window Help

-H S EBRA Y™y on W % EFW » @ Ln29 colls

I@ | | [ReadPoint |
El-#& VBAProject (Bookidsm)
: S5ub ReadPoint ()
' Create an object reference to the Excel worksheet
Dim we As Worksheet: Set ws = Worksheets ("Sheetl")
'Create a string that will be the TURL write command
‘5{ JsonConverter Dim strUrl As String
strUrl = "http://restpac.groov.com/api/vl/device/strategy/ios/analogInputs/Lamp Temperature/eu”

-

'Build HITP reguest

Dim hReqg &s New WinHttpRegquest

hReq.0Open "GET", strUrl, False

hReq.SetRequestHeader "Content-type”, "application/j=son"™

hReq.SetCredentials "rw", "rw", O 'Replace username and password with name and password defined
hReq.Send

'Read the return from the PAC. The return information will be a JSON string
Dim sctrResp As String
strResp = hReq.ResponseText
'Create an object using the JsonConverter library to read the walue from the JS0ON string.

w=2.Cells (2, 2).Value = strResp

' Dim json As Object =

Set json = JsonConverter.ParseJdson(strResp) 'Use MIT JsonConverter class

Dim tempStr As String

tempStr = json("value™) '"value" is the name returned in the JS0N. For digital points, use "state™
'See the Opto RESTful APTI for full set of returned names

'Display the parsed value in an cell
ws.Calls(:il, 2) .Value = tempStr 'Write the value to a cell

End Sub

Test

1. Return to the Excel sheet.
2. C(Click Read Point.

Cell 3B displays the parsed value:

Insert = Formulas Data

1{"value":7.05953064e+01}

70.5953064
4| Read Point |
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SNAP PAC RESTIul APl to Excel Spreadsheet

For Further Exploration

The Excel sample OptoRESTfulPAC xIsm contains interactive spreadsheets to build any read or
write command supported by your PAC. Also in this file is a sample chart that plots dataon a
time interval. These samples construct the URL paths and parse the various forms of data
returned, in addition to writing to the PAC.
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